ARCHIVES DES NEWS

Mois de Mai 2004

 

Lundi 24 Mai 2004 à 19H36, par Jets

Une nouvelle version de Edge est enfin disponible après plus de 1an sans la moindre mise à jour !
Cette version est destiné à Windows et Linux (source), pas de version Dos. Voici les nombreuses améliorations:

Bugs fixed in 1.28:
+ serious crash bug loading textures from PWads fixed.
+ savegame problem which could cause crashes fixed.
+ windows version now detects out-of-date GWA files properly.
+ windows version now handles filenames with double quotes.
+ fixed crash when a door closed on a dead player.
+ fixed (potential) crash in GL mode when depth was 8 bits.
+ crash on cast parade with flipped sprites (HellKnight) fixed.

- fix for too much bobbing.
- fix for floor textures in GL (wrong scale, no transparency).
- fixed ceilings not opening because of stuck things (MAP06).
- certain fonts are no longer forced red (QDOOM).
- fixed the issue with monsters resurrecting into another.
- render sprites (S/W mode) with posts exceeding 128 pixels.

* Many more... See the 1.28 ChangeLog for the complete list.

General improvements in 1.28:
+ better default configuration: e.g. 640x400 mode, 16 bit colour.

+ full Mlook range in GL mode.

+ better sky drawing in GL: the fake skybox copes with Mlook, never
wobbles anymore, and is drawn a lot faster than before.

+ windows version prevents more than one instance of EDGE running at
the same time. Also, window handling code has been reworked.

+ the GL renderer emulates the flat-flooding and deep-water tricks.

- better images for when you have both keycard and skullkey.
- config file remembers current language and current Save/Load page.
- Pixelfade wipe has been implemented for OpenGL mode.
- text strings look better in modes smaller than 640x400.
- the source code is now written in C++.

* See the 1.28 ChangeLog for more...


New features in 1.28:
+ very basic overlay HUD. (Better one will be made when HUD.DDF is
implemented).

+ EDGE.log file, automatically remembers all startup messages.

+ new #VERSION directive for DDF files and RTS scripts. It is followed by
the version of EDGE needed to use the DDF/RTS. E.g. "#VERSION 1.28".
This directive is _required_ to use new features in EDGE 1.28, but it
also prevents you using obsolete features (they produce a fatal error).

- RESISTANCE_CLASS for DDF. Used the same way as IMMUNITY_CLASS, but the
monster only suffers 40% of the original damage.

- TIP_GRAPHIC supports scaling via the fourth parameter, which is a value
like 0.5, 1.0, 2.0. For example:

TIP_GRAPHIC M_PAUSE 3 false 0.5

* See the 1.28 ChangeLog file for more...


Plus d'infos sur le site de EDGE.

A télécharger ici.


Mardi 18 Mai 2004 à 20H53, par Jets


Une nouvelle version de JDoom vient de sortir, il s'agit d'une version regroupant les dernières snapshots de ces derniers mois.

Plus d'infos sur le site de Doomsday.

A télécharger ici.

 

Revenir au sommaire des News